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Лабораторна робота № 1.

Ознайомлення з пакетом OrCAD Capture

Мета роботи: навчитись працювати з програмою OrCAD Capture.

Теоретичні відомості.
Загальна характеристика програми OrCAD Capture

Програма OrCAD Capture призначена для сворення проекту, частина якого може бути задана у вигляді принципової схеми, а інша частина - на мові високого рівня VHDL. Крім того, з оболонки OrCAD Capture запускаються програми моделювання аналогових, цифрових та змішаних аналогово-цифрових пристроїв Pspiee та параметричної оптимізації PSpiee Optimizer.


Рис. 1. Зв'язок OrCAD Capture з іншими програмами.

При створенні проекту відповідно до його типу автоматично завантажуються необхідні бібліотеки компонентів (пізніше їхній перелік можна змінити вручну), при цьому для всіх спеціалізованих проектів можлива передача інформації в програму OrCAD Layout для створення друкованих плат (ДП). На мал. 1 показаний взаємозв'язок OrCAD Capture з іншими програмами системи OrCAD. При створенні принципових схем проекту необхідна інформація відшукується в убудованій базі даних, що поставляється разом із системою й поповнюється користувачами. Причому при наявності опції Component Information Systems (CIS) офіційні користувачі одержують доступ через Інтернет до збільшеної бази даних, що містить інформацію приблизно про 200 тис. компонентів різних фірм (наведені їхні символи й корпуси). 

На мал. 2 зображений екран програми OrCAD Capture 9.2. У його верхній частині розташовано меню команд і нижче - панель інструментів. 
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Рис. 2. Екран програми OrCAD Capture

1. Меню команд і панель інструментів. Состав піктограм панелі інструментів залежить від обраного режиму роботи й типу поточного проекту, їхній склад зображений на мал. 3 і наведений у табл. 1. 
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Рис. 3. Піктограми панелі інструментів

Состав меню команд залежить від обраного режиму роботи й типу поточного проекту. На мал. 4 зазначений зміст меню команд при активізації менеджера проектів. 

Таблиця 1. Піктограми панелі інструментів 
	
	
	
	
	

	
	Піктограма 
	Еквівалентна команда 
	Опис команди 
	

	
	[image: image3.png]



	New 
	Створення нового документа 
	

	
	[image: image4.png]



	Open 
	Відкриття існуючого документа 
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	Save 
	Збереження внесених змін у поточному проекті 
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	Print 
	Вивід твердої копії однієї або більше сторінок поточної схеми або зображення символу компонента 
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	Cut 
	Видалення обраного об'єкта з копіюванням у буфер обміну 
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	Copy 
	Копіювання обраного об'єкта в буфер обміну 
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	Paste 
	Розміщення об'єкта з буфера обміну 
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	Undo 
	Скасування результату виконання однієї останньої команди 
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	Redo 
	Скасування результату виконання однієї останньої команди Undo 
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	Zoom In 
	Збільшення масштабу зображення 
	

	
	
	Zoom Out 
	Зменшення масштабу зображення 
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	Zoom Area 
	Вивід на весь екран облямованої частини зображення 
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	Zoom All 
	Вивід на екран повного зображення сторінки схеми 
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	Annotate 
	Призначення позиційних позначень компонентам обраної сторінки схеми 
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	Back Annotate 
	Виконання перестановок логічно еквівалентних секцій компонентів і виводів у процесі зворотного коректування 
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	Design Rules Check 
	Перевірка дотримання правил проектування DRC і правил складання електричних принципових схем ERC 
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	Create Netlist 
	Складання файлу списку з'єднань обраної сторінки схеми у форматах EDIF 200, SPICE, VHDL, Verilog, Layout й ін. 
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	Cross Reference 
	Складання файлу перехресних посилань 
	

	
	
	
	
	


	
	
	
	
	

	
	Піктограма 
	Еквівалентна команда 
	Опис команди 
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	Bill of Materials 
	Складання звіту про проект або обрану сторінку 
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	Snap to Grid 
	Прив'язка курсору до вузлів сітки на вікні редагування схем і символів компонентів (аналог команди Options>Preierences>Grid Display) 
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	Project manager 
	Завантаження менеджера проектів 
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	Help Topics 
	Вивід змісту, предметного покажчика й засобів пошуку термінів убудованої інструкції 
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Рис. 4. Состав меню команд менеджера проектів

2. Менеджер проектів розташований у лівій частині екрана програми Capture. У режимі File розгортається плоска файлова структура проекту, у режимі Hierarchy - його ієрархічна структура. Файлова структура проекту містить ряд розділів: 

Design Resource - опис проекту (файл проекту *.dsn, окремі сторінки схеми, перелік компонентів Design Cache, VHDL-файли, перелік використовуваних бібліотек компонентів *.olb); 

Outputs - результати проектування; 

PSpice Resource - інформація для моделювання за допомогою PSpice (Include Files, Model Library, Simulation Profiles, Stimulus Files) і ін. 

Подвійне натиснення лівої кнопки миші по імені конкретного файлу або по його значку завантажує його у відповідний редактор (при виборі файлу схем завантажується редактор схем, при виборі текстового файлу - убудований текстовий редактор). Натиснення правої кнопки миші по значку окремого файлу або каталогу розвертає меню, состав якого залежить від типу обраного об'єкта: 

· Add File - додавання файлу; 

· Part manager -завантаження менеджера компонентів; 

· Edit - редагування файлу; 

· Properties - перегляд і редагування властивості об'єкта; 

· New Schematic - створення нової схеми; 

· Design Properties - редагування параметрів проекту; 

· Save - збереження внесених змін; 

· Save As... - збереження внесених змін у проекті з новим ім'ям; 

· Simulate Selected Profile(s) - виконання моделювання за допомогою PSpice відповідно до обраного профайлом (файлом завдання на моделювання); 

· View Simulation Results - перегляд графічних результатів моделювання; 

· View Output File - перегляд текстового файлу результатів моделювання; 

· Edit Simulation Settings - редагування завдання на моделювання; 

· Make Active - активізація обраного профайла; 

· New Page - додавання нової сторінки схеми; 

· Edit Page - редагування сторінки схеми; 

· Schematic Page Properties - редагування параметрів настроювання схемного редактора; 

· Edit Selected object properties - редагування атрибутів обраного на схемі об'єкта; 

· Make Root - перенось обраної схеми на верхній рівень ієрархії; 

· Rename - перейменування файлу. 

3. Редактор схем. На мал. 5 показане вікно редактора сторінки принципової схеми, на якій розташовані додаткові панелі інструментів (мал. 6), команди яких перераховані в табл. 2 й 3. 
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Рис. 5. Вікно редактора сторінки схеми
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Рис. 6. Панелі інструментів редактори схем

Таблиця 2. Піктограми панелі інструментів режиму редагування схем 

	
	
	
	
	

	
	Піктограма 
	Еквівалентна команда 
	Опис команди 
	

	
	[image: image36.png]



	Select 
	Режим вибору об'єктів 
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	Part 
	Вибір у бібліотеці компонента для розміщення його символу на схемі 
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	Wire 
	Малювання електричних ланцюгів. При натисканні кнопки Shift можливе введення не ортогональних ланцюгів 
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	Net Alias 
	Розміщення псевдонімів (додаткових імен) ланцюгів і шин 
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	Bus 
	Зображення шини (лінії групового зв'язку) 
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	Junction 
	Нанесення крапки електричного з'єднання двох ланцюгів 
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	Bus Entry 
	Нанесення відводів ос шини, розташованих під кутом 45° 
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	Power 
	Розміщення символів виводів джерел живлення й «землі» 
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	Ground 
	Розміщення символів виводів джерел живлення й «землі» 
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	Hierarchical Block 
	Розміщення ієрархічних блоків 
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	Hierarchical Port 
	Розміщення портів ієрархічних блоків 
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	Hierarchical Pin 
	Розміщення виводів ієрархічних блоків 
	

	
	[image: image48.png]«




	Off-Page Connector 
	Розміщення символів з'єднувачів сторінок 
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	No Connect 
	Підключення до виводу компонента символу відсутності з'єднань 
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	Line 
	Малювання лінії 
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	Polyline 
	Малювання полілінії 
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	Rectangle 
	Малювання прямокутника 
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	Ellipse 
	Малювання еліпса /окружності 
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	Arc 


	Малювання дуги 
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	Text 
	Розміщення однієї або декількох рядків тексту із вказівкою його розміру, кольори, орієнтації й шрифту 
	

	
	
	
	
	


  

Таблиця 3. Піктограми панелі інструментів режиму моделювання 
	
	
	
	
	

	
	Піктограма 
	Еквівалентна команда 
	Опис команди 
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	New Simulation Profile 
	Створення нового файлу завдання на моделювання 
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	Edit Simulation Setting 
	Редагування завдання на моделювання 
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	Run PSpice 
	Запуск програми PSpice на моделювання 
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	View Simulation Results 
	Перегляд графічних результатів моделювання 
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	Voltage/Level Marker 
	Встановлення маркера напруги/логічного рівня 
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	Voltage Differential Markers 
	Встановлення двох маркерів різниці напруг 
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	Current Marker 
	Встановлення маркера струму 
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	Power Dissipation Marker 
	Встановлення маркера розсіює мощности 
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	Enable Bias Voltage Display 
	Відображення на схемі вузлових напруг у робочій крапці 
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	Toggle Voltage On Selected Net 
	Показати /видалити значення потенціалу по постійному струмі обраного ланцюга 
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	Enable Bias Current Display 
	Відображення на схемі струмів галузей у робочій крапці 
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	Toggle Current On Selected Part/Pin 
	Показати /видалити значення постійного струму обраного виводу компонента 
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	Enable Bias Power Display 
	Відображення на схемі розсіяної потужності в робочій крапці 
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	Toggle Power On Selected Part 
	Показати /видалити значення розсіяної потужності по постійному струму обраного компонента 
	

	
	
	
	
	


На мал. 7 зазначений зміст меню команд при активізації редактора принципових схем. 

4. Редактор символів. На мал. 8 показане вікно редактора сторінки принципової схеми, на якій розташована додаткова панель інструментів (мал. 9), перерахованих у табл. 4. 

Таблиця 4. Піктограми панелі інструментів режиму редагування символів 

	
	
	
	

	
	Еквівалентна команда 
	Опис команди 
	

	
	IEEE Symbol 
	Розміщення умовній позначці в стандарті IEEE 
	

	
	Pin 
	Розміщення виводів 
	

	
	Pin Array 
	Розміщення масивів виводів 
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Рис. 7. Состав меню команд редактори принципових схем

На мал. 10 зазначений зміст меню команд при активізації редактора символів компонентів принципових схем. 

5. Текстовий редактор. Текстовий редактор дозволяє створювати й переглядати VHDL-файли й будь-які інші текстові файли. На мал. 11 показаний фрагмент VHDL-файлу, ключові слова в якому й коментарі для наочності виділяються різними квітами, що задають у розділі Preferences меню Options. Завантаження в редактор VHDL-файлу виконуються після подвійного щиглика лівої клавіші миші при розташуванні курсору на імені файлу в менеджері проектів, текстові файли інших типів відкриваються звичайним образом по команді File>Open>Text File. 
6. Рядок станів. У нижній частині екрана Capture розташований рядок станів (мал. 12), на якому відображається ім'я обраного інструмента або меню, ім'я поточного стану програми (у лівому полі), кількість обраних об'єктів (у середнім полі), масштаб зображення й поточні координати курсору (у правому полі). 
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Рис. 8. Вікно редагування символів

[image: image72.png]it £t Yo o) Pt Tods ndon tep E

T2 = 7 e e e T B A 4]

741CTO0 Quadruple 2-input Positive-Nand Ge

Model Name. Type
T4ACTOD" SUBCKT

* The FACT Data Book, 1987, Fairchild
*ov  06/21/90 Created from LS

.subcke 74ACTOD A B Y

+ optional: DPUR=§G_DPUR DGND=§G_DGHD
+ paraws: NNTYHRDLY=0 IO_LEVEI

U1 nand(2) DFUR DGND

+ LB Y

+ D_ACTOD T0_ACT MNTYMEDLY=(MNTYHXDLY}
.ends

Ready [




Рис. 9. Панель інструментів редактори символів

7. Вибір об'єктів. Після вибору об'єкта або групи об'єктів можна виконувати різні операції, включаючи переміщення, копіювання, видалення, дзеркальне відображення, обертання, зміну масштабу й редагування. При редагуванні текстових файлів, включаючи VHDL-файли, використаються стандартні прийоми виділення об'єктів, прийняті в MS Word і подібних програмах. При редагуванні графічних файлів (принципових схем і символів окремих компонентів) виділення окремого об'єкта виробляється щигликом лівої кнопки миші при розташуванні курсору на виділюваному об'єкті (перехід у режим виділення автоматично відзначається на панелі інструментів высвечиванием іконки ) Скасування виділення об'єкта виробляється щигликом миші при розташуванні курсору на порожнім місці екрана. Додавання об'єкта у виділену групу об'єктів виконується щигликом лівої кнопки миші при натиснутій клавіші Ctrl. Видалення об'єкта з виділеної групи також виробляється при натиснутій клавіші Ctrl. Крім того можливо виділення об'єктів, розташованих у вікні (при цьому перед «натягуванням» вікна рухом курсору при натиснутій лівій кнопці миші необхідно включити режим вибору натисканням на іконку). Виділення всіх об'єктів аркуша принципової схеми виробляється по команді Edit>Select Аll. Виділення об'єктів, що перекриваються, виробляється при натиснутій клавіші Tab. 
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Рис. 10. Состав меню команд редактори символів компонентів
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Рис. 11. Перегляд і редагування VHDL-файлів
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Рис. 12. Рядок станів

8. Редагування властивостей об'єктів. Кожен об'єкт принципової схеми має набір властивостей (Properties), повністю визначальні його характеристики. До цих об'єктів ставляться: 

· Hierarchical ports - виводи ієрархічного компонента; 

· Off-page connectors - з'єднувачі сторінок схеми; 

· DRC marks - символи помилок; 

· Bookmarks - закладки; 

· Parts - символи компонентів (включаючи ієрархічні блоки); 

· Nets - ланцюга; 

· Pins - виводи компонентів; 

· Title block - основний напис аркуша принципової схеми (кутовий штамп). 

Кожна характеристика компонента (або атрибут по термінології DesignLab) має ім'я й відповідне значення. Наприклад, біполярний транзистор з позиційним позначенням Q1 має атрибут РСВ Footprint (тип корпуса), що приймає значення ТЕ206АА, атрибут Implementation Type=PSpice Model (тип математичної моделі PSpice), атрибут Implementation (ім'я математичної моделі), що приймає значення КТ315 й ін. (див. мал. 13). 
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Рис. 13. Перелік характеристик транзистора Q1

Властивості (атрибути) одного або декількох компонентів схеми проглядаються й редагуються за допомогою Property Editor, викликуваного по команді Edit>Properties (активізується також подвійним щигликом курсору на зображенні символу компонента або зі спливаючі меню, що відкриває щигликом правої кнопки миші). Перегляд електронних таблиць властивостей об'єктів проекту різних типів виконується по командах Edit>Browse>Parts, Nets менеджера проектів (див. мал. 14). Перед переглядом електронної таблиці користувач повинен вибрати тип об'єктів: 

· occurrence - об'єкти, які можуть багаторазово використатися в проекті; 

· instance - індивідуальні об'єкти, розміщені в поточному проекті (переважніше). 

В електронних таблицях можуть редагуватися тільки властивості об'єктів типу occurrence, властивості об'єктів типу instance можуть редагуватися тільки за допомогою Property Editor. 

9. Переміщення й зміна розмірів графічних об'єктів. У деяких графічних об'єктів, таких як провідники, шини (лінії групового зв'язку), лінії, еліпси (зокрема, окружності), прямокутники й багатокутники, можна змінювати розміри й форму. Всі інші об'єкти можна тільки пересувати, обертати, дзеркально відображати й видаляти.  Об'єкти, що редагують, попередньо потрібно вибрати - у результаті для кожного обраного графічного об'єкта на екрані зображуються спеціальні значки (див. мал. 15). Для зміни форми або розмірів графічних об'єктів потрібно клацнути лівої кнопки миші при розташуванні курсору на одному із цих значків і потім, не відпускаючи кнопку, перемістити відповідним чином курсор; редагування завершується 1 відпусканням лівої кнопки миші. Для переміщення будь-якого обраного об'єкта потрібно клацнути лівою кнопкою миші при розташуванні курсору в будь-якій крапці на контурі об'єкта, за винятком цих значків, і потім, не відпускаючи кнопку, виконати переміщення. При переміщенні групи об'єктів курсор змінює свою форму (він приймає форму зірочки), і його можна розташувати в будь-якої крапки усередині контуру, що облямовує обрану групу. 
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Рис. 14. Перегляд характеристик проекту в електронній таблиці
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Рис. 15. Зміна розмірів об'єктів

10. «Відкат» вперед та назад, повторення останньої операції. Команда Edit>Undo скасовує виконання останньої команди («відкат» назад), при цьому в підменю Edit до імені команди Undo автоматично додається ім'я останньої виконаної команди Place, Delete, Copy, Past, Move, Resize, Rotate, Mirror, наприклад Undo Place. Команда Edit>Redo скасовує виконання команди Edit>Undo («відкіт» уперед). 

Повторення виконання останньої команди Place, Copy, Past, Move, Resize, Rotate, Mirror виконується по команді Edit>Repeat, при цьому в підменю Edit до імені команди Repeat автоматично додається ім'я останньої виконаної команди. Для зсуву копируемого об'єкта на задану відстань потрібно перед виконанням команди Edit>Repeat Copy виділити копируемый об'єкт, нажати клавішу Ctrl й, не відпускаючи її, перемістити копируемый об'єкт на потрібну відстань. Після цього послідовне виконання команди Edit>Repeat Copy (F4) створює масив копируемых об'єктів, зміщених друг від друга на задану відстань (зручно, наприклад, при створенні шин). 

Хід роботи.

1. Вибір типу проекту 

Проекти, створені за допомогою програми OrCAD Capture, заносяться у файли з расширением. opj (по термінології, прийнятої в програмі, проект називається Project), які містять посилання на імена всіх використовуваних файлів: файлів окремих схем (*.dsn, по прийнятій термінології файли схем називаються Design, у перекладі також «проект»), бібліотек, текстових VHDL-файлів, файлів звітів про проект й ін. У файлі проекту можуть утримуватися посилання на одну або кілька папок (ці папки зображуються у вікні менеджера проектів, див. мал. 2), асоційованих з файлами принципових схем. Папка принципової схеми містить одну або кілька сторінок схеми. Файл схеми містить також Design cahe — кэш проекту, що містить копії символів компонентів, використовуваних у схемі. Проект може містити посилання на кілька бібліотек. Однак він може мати тільки одну схему (файл із розширенням імені .dsn), що складається з однієї або декількох сторінок. Можна створити новий проект і потім створити нові схеми, бібліотеки й VHDL-файли. Для створення нового проекту виконується команда File>New Project, після чого в діалоговому вікні, що відкрилося (мал. 16) на рядку Name указується ім'я проекту (символи кирилиці не допускаються, якщо передбачається моделювання), а на рядку Location - ім'я підкаталогу розташування проекту (при цьому для перегляду файлової структури зручно користуватися кнопкою Browse). Далі в середній частині цього вікна вибирається тип проекту. 

[image: image79.png]New Project

Name.

fed

Create a New Project Using

=
% (" Ainalog of Mixed A/D

" PCBoard Wiard

Schemalic

Location

Tip for New Users

Schematio Wizard i the
fastest way o create blank
schematic project

C:AProgram FestDrcad\Capture\S amples





Рис. 16. Вибір типу проекту.

2. Створення принципової схеми проекту 
2.1. Структура принципової схеми проекту 

Електричні схеми більшості проектів розміщаються на декількох сторінках не найбільшого формату. Є два способи організації схем великого обсягу: плоскі звичайні багатосторінкові структури й ієрархічні структури. 

Електричні ланцюги, розташовані на різних сторінках багатосторінкової схеми, з'єднуються один з одним за допомогою так званих міжсторінкових з'єднувачів (off-page connectors), що мають однакові імена. Всі сторінки таких схем утримуються в одній папці на тому самому рівні. Їхня структура показується в менеджері проектів при натисканні клавіші File. Наприклад, на мал. 19, а в папці SCHEMATIC 1 поміщені сторінки схеми PAGE1 й PAGE2. 

На схемах ієрархічних проектів розміщаються спеціальні символи, називані ієрархічними блоками (hierarchical block). Принципова електрична схема кожного такого блоку розміщається у вигляді окремої схеми, що поміщає в папку на тім же рівні ієрархії, що й основна схема. Ієрархічна структура показується в менеджері проектів при натисканні клавіші Hierarchy (мал. 19, б). 
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Рис. 19. Структура багатосторінкової (а) і ієрархічної (б) схеми.

2.2. Настроювання конфігурації проекту 

Перед створенням нового проекту за допомогою програми OrCAD Capture необхідно задати параметри його конфігурації за допомогою трьох команд меню Options менеджера проектів: 

· по команді Preferences задаються параметри схеми, що зберігають у файлі конфігурації Capture.ini й які ініціюються при кожному запуску програми OrCAD Capture; зміни цих параметрів вносяться у вже існуючі схеми; якщо проект створений в іншій системі OrCAD, те в увагу будуть прийняті параметри, що втримуються в поточному файлі Capture.ini; 

· по команді Design Template задаються параметри схеми, установлювані за замовчуванням при створенні всіх нових проектів (вони заносяться в розділ [Design Template] файлу Capture.ini); зміни цих параметрів не вносяться у вже існуючі схеми, тому перед створенням нових схем має сенс переглянути й при необхідності змінити їхнього значення; 

· по команді Design Properties або Schematic Page Properties задаються параметри індивідуальної поточної схеми. 

Розглянемо докладно ці способи конфігурування проектів. 

1. Команда Preferences. Закладки діалогових вікон цієї команди зображені на мал. 20. 

На закладці Color /Print (мал. 20, а) проглядаються й установлюються кольори всіх об'єктів схеми (за допомогою палітри, що відкриває щигликом лівої клавіші миші по пофарбованому прямокутнику) і позначаються об'єкти, які повинні бути виведені на печатку (для цього напроти імені об'єкта ставиться галочка в графі Print); кольори основного напису (кутового штампа, Title Block) призначається також рамці креслення (Border) і зарубкам ліній сітки на рамці креслення (Grid Reference); кольори графічних об'єктів (ліній, багатокутників і дуг) установлюються на закладці Miscellaneous, якщо ж на цій закладці зазначені кольори за замовчуванням (Default), те вони встановлюються у відповідністю з кольорами графіки (Graphics) на закладці Color/Print. 
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Рис. 20, а) 
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Рис. 20, б) 
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Рис. 20, в) 
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Рис. 20, г) 
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Рис. 20. Діалогові вікна команди Options>Preference 
На закладці Grid Display (мал. 20, б) вибирається стиль зображень сітки у вигляді крапок (Dots) або ліній (Lines) окремо для редактора схем (Schematic) і символів (Symbol); на панелі Displayed указується необхідність відображення на екрані дисплея сітки, а на панелі Pointer snap to grid відзначається необхідність «прив'язки» курсору до вузлів сітки при розміщенні об'єктів на схемі. 

На закладці Pan and Zoom (мал. 20, в) указується коефіцієнт збільшення/зменшення масштабу зображення (Zoom Factor) і коефіцієнт панорамирования (Auto Scroll Percent) для редактора схем і символів (панорамирование схеми, тобто її зсув без зміни масштабу, виробляється при наближенні курсору до границі робочого вікна, якщо натиснуто й утримується ліва кнопка миші). 

На закладці Select (мал. 20, г) установлюється,  чи будуть обрані об'єкти, якщо границя прямокутника вибору перетинає їх (Intersection) або вони повністю перебувають усередині області вибору (Fully Enclosed); на панелі Maximum number of objects to display at high resolution while dragging указується максимальна кількість відображуваних на екрані об'єктів при їхньому виборі у вікні й переміщенні. 

На закладці Miscellaneous (мал. 20, д) вибирається стиль заливання замкнутих фігур (Fill Style), стиль і ширину ліній (Line Style and Width) і кольори графічних об'єктів (Color), а також шрифт, використовуваний у менеджері проектів і файлі протоколу Session Log; крім того, установлюються наступні параметри: 

· Render True Type Tonts with strokes - зображення шрифтів True Type у вигляді векторних шрифтів stroke (для виводу на печатку); 

· Fill text - заливання шрифтів; 

· Enable Auto Recovery - автоматичне збереження файлів проектів, схем й VHDL-текстів у каталозі \WINDOWS\TEMP\AUTOSAVE; 

· Update every xxx minutes — інтервал автосохранения файлів у хвилинах; 

· Automatically reference placed parts - автоматичне присвоювання позиційних позначень розташовуваним на схемі компонентам; 

· Enable Intertool Communication (ITC) - включення режиму перевірки й відображення результатів на екрані при передачі даних від інших програм системи OrCAD, таких як OrCAD Layout й OrCAD PSpice; наприклад, при включенні режиму ITC між програмами OrCAD Capture й OrCAD Layout установлюється «гаряча» зв'язок (cross probing) між схемою й друкованою платою. 

На закладці Text Editor (мал. 20, е) конфігурується текстовий редактор, використовуваний при роботі з VHDL-файлами. На панелі Syntax Highlighting указуються кольори высвечиваемых ключових слів Keywords, коментарів Comments, рядків, укладених в апострофи Quoted Strings, і ідентифікаторів Identifiers. На панелі Current Font Setting після натискання на кнопку Set установлюється розмір шрифту тексту й кольори не высвечиваемых об'єктів. Высвечивание зазначених об'єктів виробляється при виборі панелі Highlight Keywords, Comments, Identifiers, and Quoted Strings. На панелі Tab Spacing указується інтервал табуляції текстового редактора. 

2. Команда Design Template визначає набір параметрів нових проектів, ряд з них може бути перевизначений для індивідуальних сторінок схеми. Закладки діалогових вікон цієї команди зображені на мал. 21. 

На закладці Fonts (мал. 21, а) визначаються шрифти текстів різних об'єктів, розташовуваних на схемі. 

На закладці Title Block (мал. 21, б) визначається текст, що заносить у різні графи основного напису (кутового штампа). Взагалі є основні написи двох типів: прийняті за замовчуванням й індивідуальні. У діалоговому вікні команди Design Template указується інформація, що заносить в основний напис за замовчуванням; при цьому основний напис розташовується в правому нижньому куті нового аркуша схеми (якщо в закладці Title Block правильно зазначене повне ім'я бібліотеки Library Name й якщо це бібліотека CAPSYM.OLB, те її ім'я вказувати не потрібно). Ім'я графічного символу основного напису вказується в рядку Title Block Name. Редагування тексту, занесеного в основний напис для кожної схеми, виконується в схемному редакторі по команді Edit>Properties. Індивідуально основні написи розміщаються на схемі по команді Place>Title Block. 
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Рис. 21, а) 
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Рис. 21, б) 
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Рис. 21, в) 
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Рис. 21, г) 
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Рис. 21, д) 
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Рис. 21. Діалогові вікна команди Options>Design Template 
На закладці Page Size (мал. 21, в) указується система одиниць, установлювана за замовчуванням (Inches або Millimeters), і розмір аркуша схеми А, В, З, D, Е (в англійській системі), А4, A3, А2, А1, А0 (у метричній системі) або Custom (розміри задаються користувачем). У графі Pin-to-Pin Spacing указується мінімальна відстань між виводами компонентів при їхньому розташуванні на схемі, одночасно цей параметр визначає розмір кроку сітки (відзначимо, що для існуючого проекту або індивідуальної схеми крок сітки змінити не можна, він задається перед створенням проекту, що досить незручно). Помітимо, що при зміні параметра Pin-to-Pin Spacing автоматично змінюються й розміри символів при їхньому розміщенні на новій схемі. 

На закладці Grid Reference (мал. 21, г) встановлюються параметри рамки, розташовуваної навколо аркуша схеми: 

· Count - кількість граф на рамці по горизонталі й вертикалі; 

· Alphabetic - нумерація граф за абеткою; 

· Numeric - нумерація граф у числовому порядку; 

· Ascending - проставляння номерів граф рамки в зростаючому порядку; 

· Descending - проставляння номерів граф рамки в убутному порядку; 

· Width - ширина рамки по горизонталі й вертикалі; 

· Border Visible - видимість границь сторінки на дисплеї (Displayed) і при виводі на печатку (Printed); 

· Grid Reference Visible - видимість рамки аркуша схеми на дисплеї (Displayed) і при виводі на печатку (Printed); 

· Title Block Visible - видимість основного напису на дисплеї (Displayed) і при виводі на печатку (Printed); 

· ANSI grid references - - зображення рамки аркуша схеми по стандарті ANSI. 

На закладці Hierarchy (мал. 21, д) указуються параметри, прийняті за замовчуванням при створенні нових ієрархічних блоків (Hierarchical Blocks) і компонентів (Parts): 

· Primitive - примітивні компоненти, що не мають ієрархічної структури; 

· Nonprimitive - компоненти, що мають ієрархічну структуру. 

На закладці SDT Compatibility (мал. 21, е) установлюється відповідність 8 полів параметрів символів компонентів OrCAD Capture полям символів компонентів у форматі DOS-версії OrCAD Schematic Design Tools (SDT 386+), використовуване при збереженні проекту у форматі SDT. 

3. Зміна параметрів поточного проекту виконується по команді Options>Design Properties, що має закладки Fonts, Hierarchy, SDT Compatibility, Miscellaneous (мал. 21, а, д, е, мал. 20, д); зміна параметрів поточної сторінки схеми виконується по команді Options>Schematic Page Properties, що має закладки Page Size. Grid Reference. Miscellaneous (мал. 21, в, м, мал. 20, д). Помітимо, що при цьому на закладці Page Size можна змінити розмір схеми й систему одиниць і не можна змінити параметр Pin-to-Pin Spacing, а на закладці Miscellaneous можна тільки переглянути інформацію про проект або аркуш схеми. 

  

2.3. Розміщення символів компонентів й електричних ланцюгів 

1. Розміщення символів компонентів Бібліотеки програми Capture містять у собі символи компонентів, джерел живлення й «землі». Вони розміщаються на схемі по команді Place>Part, активизируемой також натисканням на піктограму меню інструментів. У діалоговому вікні цієї команди (мал. 22, а) спочатку в списку Libraries вибирається ім'я однієї або декількох бібліотек, зміст яких відображається на панелі Part (для вибору декількох бібліотек натискається й утримується клавіша Ctrl). Після цього на панелі Part вибирається ім'я компонента, символ якого повинен бути поміщений на схему (якщо обрано кілька бібліотек, те після імені кожного компонента міститься символ / і потім ім'я бібліотеки). У розділі Graphic вибирається звичайне (Normal) або еквівалентне зображення логічних компонентів у стилі DeMorgan (Convert). У розділі Packaging указується номер секції компонента, після чого в розташованому нижче вікні виводиться зображення обраної секції компонента із вказівкою номерів цоколевки його виводів (на рядку Parts per Pkg. указується загальна кількість секцій компонента). Натисканням на кнопку Add Library відкривається діалогове вікно для додавання бібліотек у список Libraries, натискання на кнопку Remove Library видаляє обрану бібліотеку зі списку. Кнопка Part Search призначена для пошуку конкретного компонента в бібліотеках зі списку Libraries. Після натискання на кнопку ОК символ обраного компонента переноситься на схему. Рухом курсору компонент переміщається в потрібне місце схеми й фіксується натисканням лівої кнопки миші. Після цього на схему може бути розміщена ще одна копія цього ж символу. Натискання правої кнопки миші відкриває спливаюче меню (мал. 22, б), у якому дублюється виклик команд основного меню для обертання (Rotate), дзеркального відображення (Mirror), зміни масштабу зображення (Zoom), редагування параметрів компонента (Edit Properties) і ряд інших. Завершення розміщення на схемі символу обраного компонента виробляється після вибору в цьому меню команди End Mode або натискання на клавішу Esc. 
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Рис. 22.Діалогове вікно команди Place>Part (а) і спливаюче меню (б), яке активізується після вибору компонента натисканням правої кнопки миші 

Якщо не перериваючи режиму розміщення символів компонентів на схемі в спливаючому меню на мал. 22, б вибрати команду Edit Properties, виводиться діалогове вікно редагування параметрів поточного символу (мал. 23, а). У ньому є наступні поля: 

Part Value - номінальне значення параметра простого компонента (опір-ємність і т.п., прийняті в увагу при моделюванні) або найменування складного компонента (програмою моделювання в увагу не приймається); 

Part Reference — позиційне позначення компонента. Воно проставляється тут вручну, якщо на закладці Miscellaneous команди Options>Preferences (мал. 20, д) не обраний параметр Automatically reference placed parts — автоматичне присвоювання позиційних позначень розташовуваним на схемі компонентам (див. подробиці нижче). На панелі РСВ Footprint можна вибрати або скорегувати ім'я корпуса компонента. Вибір панелі Power Pins Visible указує на необхідність відображення на схемі виводів «землі» і живлення. На панелі Primitive вибирається тип компонента: Yes — елементарний (примітивний) компонент; No — компонент, що має ієрархічну структуру, Default — установлюється за замовчуванням (у відповідністю з настроюванням конфігурації на закладці Hierarchy команди Options>Design Template (мал. 21, д)). На панелі Packaging указується загальна кількість однотипних секцій компонента й ім'я (номер) поточної секції (на жаль, на цій закладці номер секції розташовуваного символу компонента змінювати не можна). 
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Рис. 23, а) 
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Рис. 23, б) 
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Рис. 23, в) 

Рис. 23. Діалогові вікна редагування параметрів символу компонента, розташовуваного на схемі (а), редагування параметрів (б), видимості їх на схемі (в) і типу їхніх моделей (г) 

Натискання на панель User Properties відкриває діалогове вікно перегляду й редагування параметрів компонента (мал. 23, б): у графі Name указується ім'я параметра, у графі Value — його значення, у графі Attributes — характеристики (атрибути) його відображення на схемі (R — тільки для читання, V — видимі на схемі, остання ознака задається на панелі Display, див. нижче). Після вибору параметра його ім'я виводиться в нижній частині вікна, а в розташованій поруч панелі виробляється уведення його значення (після натискання на клавішу Enter уведене значення відображається в графі Value) — у такий спосіб уводяться, зокрема, необхідні для моделювання за допомогою PSpice значення параметрів компонентів (на мал. 23, б зображене діалогове вікно параметрів джерела гармонійної напруги VSIN); їх можна ввести або відредагувати пізніше, по команді Edit>Properties (після створення схеми за допомогою зображених на мал. 24 діалогових вікон). 

Натискання на панель Display відкриває діалогове вікно для завдання видимості на схемі обраного параметра: 

· Do Not Display — нічого не відображати на схемі; 

· Value Only — відображати тільки значення параметра; 

· Name and Value — відображати й ім'я, і значення параметра; 

· Name Only — відображати тільки ім'я параметра; 

· Both if Value Exists — відображати й ім'я, і значення параметра, якщо його значення існує. 

Натискання на панель Attach Implementation відкриває діалогове вікно перегляду й редагування типу об'єкта, приєднаного до поточного компонента (мал. 23, г): 

· Implementation type — тип приєднаного об'єкта, що приймає значення: 

· PSpice Model - математична модель компонента для програми PSpice; 

· PSpice Stimulus - опис зовнішнього сигналу для програми PSpice; 

· Schematic View - схема об'єкта; 

· VHDL - опис компонента мовою VHDL; 

· EDIF - список з'єднань у форматі EDIF; 

· Project - схема проекту (для нього необхідно додатково задати виводи ієрархічних блоків); 

· Implementation — ім'я приєднаного об'єкта; - 

· Path and filename, — повне ім'я файлу приєднаного об'єкта. 

Поля Graphic й Packaging цього вікна (мал. 23, а) такі ж, як на мал. 22, а. 
Після розміщення компонентів на схемі можна переглянути параметри одного або декількох компонентів. Для цього вибираються компоненти, що цікавлять нас, і подвійним щигликом курсору миші або по команді Edit>Properties відкривається електронна таблиця, у якій наведені параметри обраних компонентів, приклади якої показані на мал. 24. Аналогічні таблиці містять параметри обраних ланцюгів схеми (Schematic Nets), виводів компонента (Pins) і основного напису (Title Blocks). Редагувати в цих таблицях можна тільки ті параметри, які не мають атрибута R (тільки для читання), див. мал2.23, б. Параметрам, значення яких не визначені, приділяються заштриховані осередки; після визначення їхніх значень штрихування автоматично знімається. 
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Рис. 24. Таблиці параметрів джерела гармонійного сигналу (а) і цифровий ИС 7412 (б) 

2. Проставляння позиційних позначень компонентів. Позиційні позначення компонентів (Part Reference) і номера секцій (Designator) указуються вручну або при уведенні компонентів (див. мал. 22, а й 23, а), або при редагуванні їхніх параметрів (див. мал. 4). В автоматичному режимі позиційні позначення компонентів й упакування секцій компонентів у корпуси проставляються на схемі по команді Tools>Annotate менеджера проектів або натисканням на кнопку. Діалогове вікно цієї команди наведене на мал. 25, на якому є наступні поля: 

· Scope (завдання області): 

· Update entire design - обновити позиційні позначення й пакувальну інформацію всього проекту; 

· Update selection - обновити позиційні позначення й пакувальну інформацію обраної частини проекту; 

· Action (дії): 

· Incremental reference update - обновити позиційні позначення й пакувальну інформацію компонентів, у яких замість номера проставлений знак питання «?», номера компонентів збільшуються на одиницю; 

· Unconditional reference update - відновлення позиційних позначень і пакувальної інформації всіх компонентів в обраній області; 

· Reset part reference to «?» - заміна номерів компонентів на «?»; 

· Add Intersheet Reference - додавання посилань на інші сторінки; 

· Delete Intersheet Reference — видалення посилань на інші сторінки; 

· Mode (режим відновлення): 

· Update Occurrences - відновлення параметрів всіх індивідуальних зразків компонента; 

· Update Instances - відновлення параметрів компонента й всіх посилань на нього (цей режим кращий при роботі PSpice-проектами); 

· Physical Packaging (автоматичне впакування компонентів відповідно до зазначених властивостей, наприклад упакування в певний корпус конденсаторів, ємності яких перебувають у заданих межах): 

· Combined pro'perty string - рядок властивостей; 

· Reset reference numbers to begin at 1 in each page - починати з 1 нумерацію позиційних позначень однотипних компонентів на кожній сторінці; 

· Do not change the page number - не змінювати номер сторінки. 

По команді Annotate прилеглі символи секцій многосекционных компонентів упаковуються в корпуси (мал. 26, а) і проставляються позиційні позначення компонентів у напрямку праворуч і вниз (мал. 26, б). Крім того, символам компонентів можуть бути поставлені у відповідність певні корпуси, що задовольняють ряду характеристик, зазначених у рядку властивостей Combined property string. 

3. Розміщення символів «землі» і джерел живлення. По командах Place>Ground й Place>Power або натисканням на кнопки інструментів , відкриваються діалогові вікна, приклад яких зображений на мал. 27, схожим на діалогове вікно уведення компонентів (див. мал. 22, а). Перелік символів «землі» і джерел живлення, розміщених у штатних бібліотеках CAPSYM.OLB й SOURCE.OLB, наведений у табл. 2.4. Причому ці символи можуть бути розміщені на схемі тільки за допомогою команд PlacoGround й Place>Power. Обидві ці команди еквівалентні. При цьому символи живлення мають видимі атрибути їхніх імен, які можна змінювати на панелі Name, наприклад можна вказати ім'я +5V (за замовчуванням це ім'я, відображуване на схемі, збігається з ім'ям символу). Імена Name не мають принципового значення, вони наносяться лише для більшої наочності схеми. 
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Рис. 25. Автоматичне проставляння позиційних позначень компонентів 
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Рис. 26. Автоматичне впакування компонентів (а) і проставляння позиційних позначень (б) 
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Рис. 27. Діалогове вікно введення символів живлення 

Таблиця 4. Перелік символів «землі», джерел живлення й постійних логічних сигналів 
	
	
	
	
	

	
	Бібліотека символів 
	Ім'я символу 
	Призначення 
	

	
	CAPSYM.OLB 


	GND_EARTH 
	«Земля» 
	

	
	
	GND_FIELD SIGNAL 
	«Земля» 
	

	
	
	GND_POWER 
	«Земля» 
	

	
	
	
	
	

	
	
	GND_SIGNAL 
	«Земля> 
	

	
	
	VCC_ARROW 
	Джерело живлення 
	

	
	
	VCC_BAR 
	Джерело живлення 
	

	
	
	VCC_CIRCLE 
	Джерело живлення 
	

	
	
	VCC_WAVE 
	Джерело живлення 
	

	
	SOURCE.OLB 

(для PSpice) 
	0 
	Глобальна «земля» 
	

	
	
	$D_HI 
	Логічна «1» 
	

	
	
	$D_LO 
	Логічний «0» 
	

	
	
	
	
	


Символи «землі» і живлення підключають до вузла з ім'ям 0 ланцюга або до виводів компонентів, до яких вони повинні бути приєднані (щоб переконатися в цьому, досить переглянути файли списків з'єднань *.net або завдань на моделювання *.cir). Крім символу «землі» у бібліотеку SOURCE.OLB поміщені також символи постійних логічних сигналів «1» й «ПРО». Для створення власних символів «землі» і живлення використається команда Design>New Symbol з меню менеджера команд. 

4. Розміщення символів відсутності з'єднань. По команді Place>No connect або натисканням на кнопку Ц панелі інструментів наносяться символи відсутності з'єднань No-connect (NC), які на схемі відображаються у вигляді символів «X», приєднаних до виводів компонентів. Виводи, позначені такими символами, не включаються у звіти повідомлень про помилки й у списки з'єднань. Символи NC не можуть бути вилучені натисканням на клавішу [Delete], для їхнього видалення потрібно поверх символу NC розмістити ще один такий же символ. 

5. Розміщення символів з'єднувачів сторінок. По команді Place>Off-Page Connector або натисканням на кнопку панелі інструментів відкривається діалогове вікно для нанесення на схему символів з'єднувачів сторінок. У штатній бібліотеці CAPSYM.OLB є два символи з'єднувачів сторінок L й R. На панелі Name діалогового вікна вводяться імена з'єднувачів сторінок, які автоматично привласнюються іменам, що приєднують до них ланцюгів. Ланцюга, розташовані на одній або різних сторінках схеми й однакові імена, що мають, уважаються соединенными з'єднаними. 
6. Розміщення електричних ланцюгів. Провідники ланцюгів розміщаються по команді Place>Wire, натисканням комбінації клавіш Shft+W або натисканням на кнопку панелі інструментів. Початок уведення ланцюга відзначається щигликом лівої кнопки миші, поле чого курсор змінює свою форму, здобуваючи вид хреста. Ланцюг прокладається рухами курсору. Кожен злам провідника фіксується щигликом лівої кнопки миші. Таким чином, у ланцюзі можна зробити ортогональні злами під кутами, кратними 90°. Уведення провідника під довільним кутом виробляється при натиснутій клавіші Shift. Уведення поточного ланцюга завершується, якщо її кінець збігається з виводом компонента або будь-якою крапкою іншого ланцюга. Примусове завершення уведення ланцюга виконується подвійним щигликом лівої кнопки миші, після чого можна провести інший провідник. Режим уведення ланцюгів завершується натисканням клавіші Esc або вибором рядка End Wire у спливаючому меню, що відкриває щигликом правої кнопки миші. 

Якщо ланцюги починаються або закінчуються в будь-якій крапці сегмента іншого провідника або на виводі компонента, між ними встановлюється електричне з'єднання. Ознакою приєднання ланцюга до виводу є зміна його форми - провалля квадратика на його кінці. Пересічні сегменти провідників не з'єднуються один з одним. Їхнє з'єднання виконується подвійно: 

· при прокладці провідника, що перетинає, потрібно зупинитися в крапці з'єднання й двічі клацнути лівою кнопкою миші - у результаті з'єднання буде позначено спеціальною крапкою (junction); 

· для з'єднання пересічних провідників курсор установлюється в крапку перетинання й виконується команда Place>Junction, натискається комбінація клавіш Shft+J або кнопка на панелі інструментів; для скасування електричного з'єднання необхідно поверх крапки з'єднання розмістити іншу таку крапку. 

Якщо при розміщенні компонентів на схемі один або кілька виводів стикаються, між ними встановлюється електричне з'єднання, і якщо потім ці компоненти розсунути, автоматично прокладається провідник. 

Якщо при переміщенні компонента або фрагмента схеми закорочується ряд ланцюгів, то виводиться зображене на мал. 28 попереджуюче повідомлення й закорочені ланцюги висвічуються. Для скасування цього переміщення необхідно нажати на кнопку ОК і потім виконати команду Edit>Undo Move. Переміщення ланцюгів беа обліку їхніх електричних з'єднань виробляється при натиснутій клавіші Alt. 
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Рис. 28. Попередження про замикання ланцюгів 

При розміщенні ланцюгів їм автоматично привласнюються системні імена. наприклад N01049, які неможливо змінити. Однак у списки з'єднань заносяться так називані псевдоніми (Alias) ланцюгів, які для обраного ланцюга визначаються по команді Place>Net Alias, ініцийовані також натисканням комбінації Shift+N або натисканням на кнопку панелі інструментів. Кожен ланцюг може мати кілька псевдонімів, з яких у таблиці Properties вибирається поточний псевдонім, що і використається при складанні списку з'єднань.

На схемі провідники зображуються лініями стандартної ширини 0,2 мм при масштабі 1:1 (змінити цю ширину, на жаль, не можна). Лініями такої ж товщини зображуються лінії контурів символів компонентів й їхні виводи (див. мал. 5).

7. Розміщення ліній групового зв'язку (шин). Лінії групового зв'язку (шини) уводяться по команді Place>Bus (Shift+B) або натисканням на кнопку панелі інструментів. На схемі вони зображуються більше широкими лініями, чим провідники (мал. 29). Відводи окремих ланцюгів, нахилені під кутом 45°, уводяться по команді Place>Bus Entry (Shift+B) або натисканням на кнопку по тим ж правилам, що й окремі ланцюги. При цьому зручно копіювати сегменти ланцюгів, перетаскуючи їх при натиснутій клавіші Ctrl, зберігаючи вихідний об'єкт незмінним. Імена (псевдоніми) шин і вхідних у їхній состав ланцюгів призначаються по команді Place>Net Alias, причому при проставлянні імен окремих ланцюгів їхнього номера, пропоновані в діалоговому вікні команди, автоматично збільшуються на одиницю, наприклад, ADDR1, ADDR2, ADDR3, ADDR4. Ім'я шини, що складає із цих провідників, записується по форматі: ADDR[1..4]. На схемі шини зображуються лініями стандартної ширини 0,8 мм (при масштабі 1:1).
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Рис. 29. Зображення шини.

ЗАВДАННЯ

1. Створити принципову схему згідно варіанту за допомогою програми OrCAD Capture.

2. Зробити та захистити звіт з лабораторної роботи.

Лабораторна робота № 2.

Ознайомлення з пакетом OrCAD Capture

Мета роботи: навчитись створювати та редагувати компоненти за допомогою програми OrCAD Capture.

Теоретичні відомості.
Створення й редагування компонентів

В OrCAD Capture можливо створювати символи компонентів і потім поміщати їх в існуючі або нові бібліотеки. Для створення або редагування символів використається Part Editor, доступ до якого здійснюється одним із трьох способів. 

1. Для створення нового символу створюється нова або відкривається існуюча бібліотека й потім вибирається команда Design>New>Part. 
2. Для редагування існуючого символу в менеджері проектів відкривається бібліотека символів і потім подвійним щигликом курсору вибирається потрібний символ. 

3. Для редагування символу, розміщеного на схемі, він вибирається одинарним щигликом курсору й потім виконується команда Edit>Part. 
Створення нового символу. Залежно від свого призначення символи створюються двома різними командами. 

1) По команді Design>New Symbol (див. мал. 1, а) створюються допоміжні символи чотирьох типів: 

· Power - символ підключення ланцюгів «землі» й «живлення»; 

· Off-Page Connector - символ з'єднувача сторінок схеми; 

· Hierarchical Port - символ ієрархічного блоку; 

· Title Block - символ основного напису («кутового штампа»), його приклад, виконаний по ЕСКД, наведений на мал. 2. 

У графі Name (мал. 1, а) указується ім'я символу, а в графі Symbol Турі вибирається його тип. Символи цих типів розміщаються на принципових схемах й їм не відповідають фізично існуючі компоненти. Типи цих допоміжних символів приймаються в увагу тільки при виконанні команд Place>Power, Place>Ground, Place>Off-Page Connector, Place>Hierarchical Port, Place>Title Block — у діалогових вікнах команд (див. мал. 22, а(1л.р.),) у каталог обраної бібліотеки міститься тільки список компонентів відповідного типу. 
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Рис. 1. Діалогове вікно команд Design>New Symbol й Design>New Part
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Рис. 2. Приклад символу основного напису .(Title Block)

2) Символи всіх інших компонентів, більшість із яких мають фізично існуючі корпуси, уводяться по команді Design>New Part. У діалоговому вікні цієї команди (мал. 1, б) уводяться наступні дані: 

· Name - ім'я символу; 

· Part Reference Prefix - префікс позиційного позначення (наприклад, R для резистора, Із для конденсатора, DA для аналогової ИС, DD для цифровий ИС і т.п.); 

· РСВ Footprint - ім'я типового корпуса компонента, наприклад, DIP16, SOI24, якщо він існує (цей параметр обов'язковий тільки при передачі схеми для розробки друкованої плати, при виконанні моделювання він не потрібний); 

· Create Convert View - необхідність створення другого зображення символу (наприклад, еквівалента DeMorgan для елементів цифрової логіки); 

· Parts per Package - загальна кількість секцій у корпусі компонента; 

· Homogeneouse або Heterogeneouse - вибір між компонентами із секціями однакового або різного типу (наприклад, ИС 133ЛАЗ, що містить 4 логічних елементи 2И-НІ, ставиться до класу Homogeneouse, а ИС 564ЛП2, що містить 2 логічних елементи ЗИЛИ-НІ й елемент НЕ, ставиться до класу Heterogeneouse); 

· Alphabetic або Numeric - вибір між позначеннями секцій многосекционных компонентів буквами латинського алфавіту, наприклад DD1A, DD1B, DD1C і т.д. (буквами латинського алфавіту можна позначати секції компонентів, що містять до 26 секцій в одному корпусі) або цифрами, наприклад DD1-1, DD1-2, DD1-3; 

· Part Aliases - визначення псевдонімів символів для -зменшення обсягу . бібліотек (наприклад, можна створити компонент LA3 і привласнити йому псевдоніми 133LA3, K155LA3, 530LA3); 

· Attach Implementation - підключення додаткового опису символу за допомогою еквівалентної схеми, VHDL-файлу, списку з'єднань, іншого проекту або у вигляді моделі PSpice; 

· Pin Numbers Visible - відображення на схемі номерів виводів. 

Після натискання на панель ОК діалогових вікон команд Design>New Part або Design>New Symbol відкривається робоче поле Part Editor (мал. 3), на якому штрих-пунктирним прямокутником обмежені габарити символу (розміри цього прямокутника змінюються звичайним образом «буксируванням» його кутів). Виводи компонента повинні бути розміщені поза цим прямокутником, стикаючись із ним. Виводи компонента розміщаються по команді Place>Pin , діалогове вікно якої зображено на мал. 4, а. На ньому вказується наступна інформація: 

· Name - ім'я виводу; 

· Number - номер виводу; 

· Shape - форма виводу (див. табл. 1); 
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Рис. 3. Заготівля символу

· Турі — тип виводу (див. табл. 2), що використається тільки при виконанні перевірок правильності складання схеми по команд'е Tools>Design Rules Check (DRC); 

· Scalar або Bus - вибір між одиночним виводом або шиною; 

· Pin Visible - відображення виводу на схемі (тільки для виводів типу Power), у вікні Edit Part такі виводи відображаються без вказівки їхніх імен і номерів; 

· User Properties - відкриття діалогового вікна перегляду й редагування характеристик виводу компонента перед його розміщенням на робочому полі 

Нижче контуру компонента автоматично розміщається атрибут <Value> (його розташування можна змінити, розміщаючи його й усередині контуру), якщо його значення не визначене, то на схемі в якості його значення автоматично вказується ім'я компонента. 

Таблиця 1. Графіка виводів 
	
	
	
	

	
	Форма (Shape) 
	Опис 
	

	
	Clock 
	Вхід синхронізації 
	

	
	Dot 
	Ознака логічного заперечення 
	

	
	Dot-Clock 
	Вхід синхронізації з інвертуванням 
	

	
	Line 
	Стандартний вивід, довжина якого дорівнює трьом крокам сітки 
	

	
	Short 
	Короткий вивід, довжина якого дорівнює одного кроку сітки 
	

	
	ZeroLength 
	Стандартний вивід нульової довжини 
	

	
	
	
	


  

Таблиця 2. Типи виводів 
	
	
	
	

	
	Тип виводу 
	Опис 
	

	
	3-State 
	Тристабильный вивід, що має три можливих стани: логічний стан низького рівня, догическое стан високого рівня й стан великого вихідного опору (Z-стан, це стан еквівалентно розриву ланцюга). Наприклад, 8-розрядний регістр-засувка 74LS373 (КР1533ИР22) має тристабильные виводи 
	

	
	Bidirectional 
	Двунаправленный вивід (може бути як входом, так і виходом компонента) 
	

	
	Input 
	Вивід подачі вхідного сигналу 
	

	
	Open Collector 
	Вихід вентиля з відкритим колектором (до нього підключається резистор навантаження) 
	

	
	Open Emitter 
	Вихід вентиля з відкритим эмиттером (до нього підключається резистор навантаження) 
	

	
	Output 
	Вихід компонента 
	

	
	Passive 
	Вивід пасивного компонента (резистора, конденсатора, діода й т.п.) 
	

	
	Power 
	Виводи для підключення ланцюгів «землі» й «живлення». Наприклад, для ИС серії 133 живлення підключаються до виводу 14, а «земля» — до виводу 7. Імена цих виводів повинні збігатися з іменами відповідних ланцюгів 
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Рис. 4. Діалогове вікно розміщення окремого виводу компонента.(а) і масиву виводів (б)

Розміщення масивів виводів виробляється по команді Place>Pin Array , діалогове вікно якої зображено на мал. 4, б. На ньому вказується інформація: 

· Starting Name - ім'я першого виводу масиву. Якщо ім'я виводу закінчується однієї із цифр 0...9, то в іменах наступних виводів до неї послідовно додається величина, що задає параметром Increment. Якщо зверху від імені потрібно проставити знак заперечення у вигляді горизонтальної риси, то після кожного символу такого імені вводиться коса риса «\». Наприклад, уведення символів R\E\S\E\T\ визначає ім'я RESET; 

· Starting Number - номер першого виводу масиву; 

· Number of Pins - кількість виводів у масиві; 

· Increment - збільшення імен виводів, що проставляють автоматично, масиву (якщо ім'я першого виводу закінчується цифрою); 

· Pin Spacing - відстань між сусідніми виводами масиву в одиницях кроку сітки; 

· Shape - форма виводу (див. табл. 6); 

· Турі - тип виводу (див. табл. 7); 

· Pins Visible - відображення виводів схемі (тільки для виводів типу Power). 

Секції як однорідних, так і неоднорідних компонентів можуть мати загальні виводи, звичайно це виводи підключення ланцюгів «землі» й «живлення», тобто виводи типу Power. Звичайно ці виводи невидимі й вони вважаються підключеними до ланцюгів, імена яких збігаються з іменами виводів. Для неоднорідних компонентів виводи «землі» й «живлення» досить проставити принаймні на одній секції, для однорідних компонентів ці виводи автоматично проставляються у всіх секціях (при цьому всієї їхньої копії мають однакові імена й номери), тому їх завжди роблять невидимими на схемі. Щоб зробити видимими всі виводи «землі» й «живлення» (для цілей документування), потрібно в менеджері проектів вибрати щигликом курсору ім'я потрібного проекту й у меню Options вибрати команду Design Properties, після цього на закладці Miscellaneous вибрати опцію Display Invisible Power Pins. 

Послу нанесення виводів секції рисується її контур і наносяться додаткові текстові написи (див. мал. 5, а). При цьому по команді Рlасе>IЕЕЕ Symbols зручно нанести функціональні символи, показані в табл. 8. По команді View>Next Part відкривається зображення наступної секції — для однорідних компонентів досить тільки нанести номера виводів (вибираючи їх послідовно щигликами курсору), як показано на мал. 5, б; для однорідних компонентів зображення кожної секції рисується заново. Перегляд зображень всіх секцій многосекционных компонентів виконується по команді View>Package (див. мал. 5, в), перехід до редагування окремої секції виробляється щигликом курсору. 

Параметри компонента вводяться по команді Options>Part Properties, діалогове вікно якої показано на мал. 23, б(1л.р.),. Параметри впакування компонента вводяться по команді Options>Pakage Properties, діалогове вікно якої показано на мал. 6. Складання знову всіх цих параметрів являє собою досить кропітке завдання, тому при створенні нового компонента доцільніше скопіювати в бібліотеку символів засобами Windows однотипний компонент і потім відредагувати його параметри. 
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Рис. 5. Введення графіки й номерів виводів окремих секцій однорідного компонента (а, б) і перегляд упакування трисекційного компонента (в)
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Рис. 6. Введення параметрів упакування компонента

Геометричні розміри символу пов'язані із прийнятим при його побудові кроком сітки. Якщо при уведенні символу на схему змінити цей крок (він покладається рівним параметру Pin-to-Pin Spacing на закладці Page Size, мал. 21, в)(1л.р.), то пропорційно зміняться й розміри всіх символів. Тому при створенні бібліотек символів рекомендується заздалегідь вибрати й установлювати те саме значення параметра Pin-to-Pin Spacing. 

Зауваження. 
Як імена компонентів в OrCAD Capture допускається вводити символи кирилиці, наприклад 133ИР7, однак робити це не рекомендує ся, тому що немає ніяких, гарантій, що не виникнуть помилки надалі, наприклад, при передачі даних в інший модуль OrCAD або в іншу систему проектування. Що стосується імен виводів, то в них символи кирилиці не допускаються. Взагалі в імпортних САПР щоб уникнути непорозумінь рекомендується по можливості використати символи кирилиці тільки в текстових написах. 

Таблица 3. Символи IEEE 
	
	
	
	

	
	Символ 
	Символ 
	

	
	3 State 
	LE 
	

	
	Active Low Left 
	NE 
	

	
	Active Low Right 
	Non Logic 
	

	
	Amplified Left 
	Open Circuit H-type 
	

	
	Amplified Right 
	Open Circuit L-type 
	

	
	Analog 
	Open Circuit Open 
	

	
	Arrow Left 
	Passive Pull Down 
	

	
	Arrow Right 
	Passive Pull Up 
	

	
	BiDirectional 
	Pi й 
	

	
	Dynamic Left 
	Postponed 
	

	
	Dynamic Right 
	Shift Left 
	

	
	GE 
	Shift Right 
	

	
	Generator 
	Sigma 
	

	
	Hysteresis 
	
	


ЗАВДАННЯ

3. Створити компоненти, які входять в принципову схему згідно варіанту, за допомогою програми OrCAD Capture, .

4. Зробити та захистити звіт з лабораторної роботи.

Лабораторна робота № 3.

Підготовка проекту до створення друкованої плати за допомогою  OrCAD Capture разом з OrCAD Layout
Мета роботи: створити список зв’язків та корпуси відповідних компонентів схеми.

Теоретичні відомості.

Створення списку з'єднань

Для продовження проектування після створення схемного опису проекту виконується команда Tools>Create Netlist менеджера проектів. При виконанні моделювання за допомогою OrCAD PSpice ця команда завантажується автоматично; для передачі даних у програму розробки ДП OrCAD Layout й інші (усього передбачене складання списку з'єднань приблизно в 40 форматах, обираних користувачем) ця команда виконується вручну, попередньо виділивши ім'я проекту в менеджері проектів. 

Перед виконанням моделювання потрібно виключити повтори позиційних позначень компонентів, а перед розробкою ДП необхідно також зробити впакування секцій компонентів у корпуси. Ці операції виконують по команді Tools>Annotate менеджера проектів, діалогове вікно якої показано на мал. 25 (див. Л.р.1). 

Перед створенням списку з'єднань бажано виконати команду Tools>Design Rules Check (DRC) для виявлення помилок у схемі (при запуску програми PSpice на моделювання ця команда завантажується автоматично, але в кожному разі потрібно попередньо задати її конфігурацію). Звіт про перевірку заноситься у файл *.drc і дублюється у файлі протоколу Session Log (no вказівці користувача місця розташування помилок відзначаються на схемі спеціальними DRC-маркерами ф). 

У звіти заносяться повідомлення про порушення правил проектування двох типів: 

· Errors - помилки, які обов'язково повинні бути виправлені; 

· Warnings - попередження, які можуть привести до помилок при моделюванні проекту (реагувати на них не обов'язково). 

Після запуску команди Design Rules Check відкривається діалогове вікно для завдання правил перевірки, що має дві закладки (мал.1). 

На закладці Design Rules Check (мал.1, а) установлюється, яка інформація включається у звіт про перевірку: 

· Scope - перевірка всього проекту (Check entire design), обраної сторінки або декількох сторінок (Check selection); 

· Action - перевірка дотримання всіх правил проектування (Check design rules) або видалення зі схеми нанесених раніше DRC-маркерів; 

· Report (вибір інформації, що включає у звіт про перевірку): 

· Create DRC markers for warnings - розміщення символів DRC для попередження про можливі помилки у відповідність із правилами, заданими в таблиці ERC (у місцях виникнення безумовних помилок DRC-маркери проставляються завжди); 

· Check hierarchical port connections - перевірка збігу імен ієрархічних виводів і відповідних ієрархічних портів у їхніх схемах заміщення, а також збігу їхньої загальної кількості й типів всіх виводів; 

· Check off-page connector connections - перевірка збігу імен з'єднують між собою межстраничных з'єднувачів (приєднаних до ланцюгів з однаковими іменами), розташованих на різних сторінках схеми; 

· Report identical part references - включення у звіт списку компонентів, що мають однакові позиційні позначення; 

· Report invalid packaging - включення у звіт списку компонентів, що мають однакові корпуси, але різну пакувальну інформацію 

· Report hierarchical ports and off-page connectors - складання списку всіх портів ієрархічних блоків і межстраничных з'єднувачів; 

· Check unconnected nets - виявлення ланцюгів, кожна з яких не з'єднана принаймні із двома виводами компонентів або не підключена до джерел зовнішніх сигналів, а також ланцюгів, що мають на різних сторінках схеми однакові імена, але до яких не підключені межстраничные з'єднувачі або ієрархічні порти; 

· Check SDT compatibility - перевірка сумісності із графічним редактором принципових схем OrCAD SDT для DOS (ця сумісність необхідна, якщо передбачається зберегти схему проекту у форматі OrCAD SDT); 

· Report off-grid objects - складання списку імен і координат об'єктів, розташованих не у вузлах сітки; 

· Report all net names - складання списку всіх імен ланцюгів. 

· Report File - присвоєння імені файлу звіту (за замовчуванням його ім'я збігається з ім'ям проекту, розширення імені drc); 

· View Output - перегляд на екрані результатів перевірки. 

На закладці ERG Matrix установлюються правила перевірок, які записуються у вигляді матриці Electrical Rules Check (ERC, мал. 1, б). На рядках і стовпцях матриці зазначені типи виводів компонентів і різних портів. Не зафарбований осередок означає дозвіл з'єднання відповідних виводів, попередження відзначаються символом W, помилки — символом Е. Наприклад, відповідно до зображеного на мал. 1, б матриці ERC з'єднання Output-Input (Вихід-Вхід) дозволено, про з'єднання Open Emitter-Open Collector (Відкритий эмиттер-Открытый колектор) буде виведене попередження, а з'єднання Power-Output (Джерело живлення-вихід) буде вважатися помилкою. 

Тому перед виконанням команди Tools>Design Rules Check необхідно відредагувати зміст матриці ERC у відповідність із особливостями поточного проекту. 

Приведемо приклад файлу звіту про результати перевірки проекту. 
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Рис. 1. Завдання конфігурації команди Tools>Design Rules Check
• Design Rules Check 

********************************************* 

Checking for Invalid Pins in Package (Перевірка помилкових приєднань виводів) ERROR [DRC0031]. Same Pin Number connected to more than one net. U11 A/3 Nets: 'N00049_3009' and 'N00049': PICD, PAGE1 (3.20, 2.10) 

(Помилка [DRC0031]. Деякі виводи з'єднані більш, ніж з одним ланцюгом. Ланцюга 1М00049_3009 й N00049 з'єднані з виводом U11A/3. Схема PICD, сторінка PAGE1, координати виводу (3.20, 2.10)} 

Checking Schematic: FRQCHK 

Checking Electrical Rules 

WARNING: [DRC0005] Unconnected pin U24/5D: SDLXLE, PAGE1 (1.80, 4.00) 

(Попередження [DRC0005]. He приєднаний вивід U24/5D. Схема SDLXLE, 

сторінка PAGE 1, координати виводу (1.80,4.00)) 

Checking for Invalid References (Перевірка невірних позиційних позначень) 

Checking for Duplicate References (Перевірка дублювання позиційних позначень) 

Після виправлення виявлених помилок можна виконати команду Tools>Create Netlist для складання списку з'єднань проекту. У діалоговому вікні цієї команди є 9 закладок для вибору формату списку з'єднань (мал. 2). Перші 8 закладок пов'язані з певними форматами: 

· EDIF 200 - формат Electronic Data Interchange Format, що має два різновиди; з підтримкою (hierarchical netlist) або без підтримки (flat netlist) ієрархічної структури (залежно від обраної конфігурації системи); 

· PSpice (файли *.net), SPICE (файли *.cir) - формат програм моделювання PSpice й SPICE (ієрархічні блоки представляються у вигляді макромоделей за допомогою директиви .SUBCKT); 

· VHDL (файли *.vhd), Verilog (файли *.v) - опису цифрових пристроїв на мовах VHDL й Verilog; 

· Layout - список з'єднань проекту у форматі програми розробки друкованих плат OrCAD Layout (бінарні файли *.mnl); 

· INF - передача даних у стару версію DOS-програми моделювання OrCAD Digital Simulation Tools 386+ (файли *.inf). 

Залежно від обраного формату користувач повинен зробити настроювання форми вихідного файлу відповідно до особливостей проекту (наприклад, для формату OrCAD Layout, див. мал. 2.48, включення опції Run ECO to Layout приведе до автоматичної передачі в програму розробки друкованої плати OrCAD Layout нового (зміненого) файлу .mnl, при цьому раніше в Layout повинна бути завантажена стара плата). Натисканням на дев'яту закладку Other можна вибрати ще близько 40 форматів, з яких найбільш відомі наступні: Allegro, EEDesigner, Intergraph, HiLo, Mentor, PADS, P-CAD, Scicards, Tango, VST. Відзначимо, що список з'єднань у форматі програми Allegro PCB Layout (Unix й NT) фірми Cadence може бути складений також по команді Accessories>Allegros>Allegro Netlist. 
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Рис. 2. Вибір формату списку з'єднань у діалоговому вікні команди Create Netlist.

Використання OrCAD Capture разом з OrCAD Layout

При створенні за допомогою OrCAD Capture принципової схеми, призначеної для розробки друкованої плати за допомогою OrCAD Layout, необхідно виконати ряд умов, щоб у майбутньому не виникало помилок при спробі перенести схему на ДП. 

1. Всім компонентам схеми необхідно поставити у відповідність їхнього корпуса за допомогою атрибута Footprint (із числа тих, які є в бібліотеках OrCAD Layout); 

2. За допомогою атрибутів компонентів, ланцюгів і виводів компонентів, перерахованих у табл: 1 — 3, можна задати додаткові дані на друковану плату (в атрибутах дозволяється використати тільки заголовні букви). Атрибути задаються або вручну, або заповнюючи стандартні форми (див. приклад на мал. 3), які викликаються по командах Macro>Configure. 
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Рис. 3. Діалогове вікно для уведення стандартних атрибутів компонентів

Таблиця 1. Атрибути компонентів 
	
	
	
	
	

	
	Ім'я параметра компонента 
	Приклад значення 
	Опис параметра 
	

	
	COMPFIXED 
	YES 
	Присвоєння значення YES фіксує розташування компонента на платі 
	

	
	COMPGROUP 
	2 
	Присвоєння номера групи розміщення компонента на платі 
	

	
	COMKEY 
	YES 
	Присвоєння компоненту ознаці ключового компонента в даній групі; такі компоненти розміщаються першими перед іншими компонентами групи 
	

	
	COMPLOC 
	[1000,1000] 
	Координати [X,Y] розміщення компонента на платі, X й Y — цілі числа (в англійській системі координати відраховують у милах, а в метричній у мікронах) 
	

	
	
	
	
	


  

	
	
	
	
	

	
	Ім'я параметра компонента 
	Приклад значення 
	Опис параметра 
	

	
	COMPLOCKED 
	YES 
	Присвоєння значення YES тимчасово фіксує розташування компонента на платі 
	

	
	COMPROT 
	270.00 
	Кут повороту компонента на платі проти вартовий стрілки (у град, і хвилинах) щодо його орієнтації в бібліотеці 
	

	
	COMPSIDE 
	ОТ 
	Вибір сторони плати при розміщенні компонента (ТОР або ОТ) 
	

	
	FOOTPRINT 
	DIP16 
	Ім'я корпуса компонента 
	

	
	FPLIST 
	DIP24\400 
	Список альтернативних корпусів компонентів (як роздільник списку використається кома) 
	

	
	GATEGROUP 
	1 
	Присвоєння секції компонента номера групи. Дві секції можуть бути переставлені, якщо вони належать тому самому корпусу й входять у ту саму групу (тобто мають однакові параметри GATEGROUP) 
	

	
	MIRRORFOOTPRINT 
	DIP24-M 
	Ім'я зображення дзеркального відображення корпуса компонента 
	

	
	PARTNUM 
	489746 
	Номер компонента, що привласнює користувачем (використається при випуску документації) 
	

	
	PARTSHAPE 
	74LS04 
	Тип компонента, наприклад, 74LS04, СК05 або Т05. У відсутності атрибута FOOTPRINT з найменуванням корпуса компонента значення атрибута PARTSHAPE використається для пошуку підходящого корпуса у файлі SYSTEM.PRT 
	

	
	POWERPIN 
	YES 
	Визначення компонента, що містить один вивід 
	

	
	
	
	
	


  

Таблиця 2. Атрибути ланцюгів 
	
	
	
	
	

	
	Ім'я параметра ланцюга 
	Приклад значення 
	Опис параметра 
	

	
	CONNWIDTH 
	10 
	Значення ширини провідника за замовчуванням 
	

	
	HIGHLIGHT 
	YES 
	Дозвіл підсвічування обраного ланцюга 
	

	
	MAXWIDTH 
	12 
	Максимальна ширина провідника 
	

	
	MINWIDTH 
	8 
	Мінімальна ширина провідника 
	

	
	NETGROUP 
	2 
	Завдання номера групи ланцюгів. Об'єднання ланцюгів у групи використається при редагуванні й трасуванні провідників 
	

	
	NETWEIGHT 
	60 
	Целочисленный вагарні множник (у діапазоні від 1 до 100, за замовчуванням 50), що позначає пріоритет ланцюга при трасуванні 
	

	
	RECONNTYPE 
	ECL 
	Завдання правила трасування (STD, HORZ, VERT, MIN, МАХ або ECL) 
	

	
	SPACINGBYLAYER 
	ТОР=13, ОТ=8 
	Зазор між трасами на одному або декількох шарах 
	

	
	
	
	
	


  

	
	
	
	
	

	
	Ім'я параметра ланцюга 
	Приклад значення 
	Опис параметра 
	

	
	TESTPOINT 
	YES 
	Автоматичне створення контрольної крапки для даного ланцюга (YES) 
	

	
	THERMALLAYERS 
	GND 
	Список імен шарів металізації, до яких приєднується даний ланцюг (як роздільник списку використається кома) 
	

	
	VIAPERNET 
	VIA1 
	Тип перехідного отвору, дозволеного для даного ланцюга 
	

	
	WIDTH 
	12 
	Ширина провідника. За замовчуванням це значення привласнюється параметрам MinWidth, MaxWidth й ConnWidth WIDTHBYLAYER 
	

	
	
	
	
	


  

Таблиця 3. Атрибути виводів компонентів 
	
	
	
	
	

	
	Ім'я параметра виводу компонента 
	Приклад значення 
	Опис параметра 
	

	
	ECLTYPE 


	SOURCE 
	Присвоєння типу виводу Source, Load або Target при використанні алгоритму трасування Daisy-chain 
	

	
	PINGROUP 
	1 
	Присвоєння виводу номера групи, до якого він належить. Два виводи можуть бути переставлені, якщо вони належать однієї й тій же секції компонента й входять у ту саму групу (тобто мають однакові параметри PINGROUP) 
	

	
	
	
	
	


Після створення схеми проекту в OrCAD Capture можна створити файл списку його з'єднань (*.mnl) для передачі в OrCAD Layout для розробки друкованої плати. Попередньо потрібно скопіювати поточний файл конфігурації Layout.ini у каталог, у якому перебуває програма Capture.exe, потім відкрити OrCAD Capture і виконати команду Tools>Create Netlist, вибравши в її діалоговому вікні закладку Layout. Після цього необхідно закрити OrCAD Capture, завантажити програму OrCAD Layout і передати їй файл списку з'єднань. Це робиться двома способами. 

1. На закладці Layout команди Tools>Create Netlist можна відзначити опцію Run ECO, тоді після складання списку з'єднань він буде автоматично переданий в OrCAD Layout, і в поточній платі будуть виконані відповідні зміни (завантажені відсутні корпуси компонентів, вилучені зайві й скоректовані електричні з'єднання, тобто виконане коректування друкованої плати за даними про принципову схему). Якщо при цьому файл друкованої плати з попередньо розміщеними компонентами відкритий, то буде виведений запит на підтвердження завантаження файлу списку з'єднань; якщо ж файл друкованої плати не відкритий, то OrCAD Layout виведе запит на підтвердження завантаження модифікованого списку з'єднань після повторного відкриття файлу друкованої плати. 

2. Для створення нової друкованої плати в OrCAD Layout виконується команда File>New й у діалогових вікнах указується ім'я файлу шаблона друкованої плати (*.tch), ім'я файлу списку з'єднань (*.mnl) і ім'я файлу створюваної друкованої плати (*.mах). 

Зауваження. 
При завантаженні в OrCAD Layout списку з'єднань принципової електричної схеми кожному компоненти схеми ставиться у відповідність його корпус (Footprint). Якщо серед параметрів якого-небудь компонента не зазначене ім'я його корпуса, то в увагу приймаються відповідності, зазначені у файлі SYSTEM.PRT. 

Між екранами Capture й Layout можна встановити «гарячий зв'язок» (Cross probing). Для цього необхідно одночасно відкрити обидві ці програми й завантажити в них той самий проект, розташовуючи зображенн схеми й друкованої плати в різних вікнах (в Layout при цьому можна виконати команду Window>Half Screen). У програмі Capture необхідно на закладці Miscellaneous команди Options>Properties вибрати опцію Enable Intertool Communication, у програмі Layout ніяких спеціальних дій уживати не треба. Після цього вибір одного або кілька об'єктів на екрані Capture высвечивает відповідні їм об'єкти на екрані Layout і навпаки. 

Прямая й зворотне коректування проекту. При розробці друкованих плат бажано, щоб на кожному кроці проектування принципова схема проекту повністю відповідала друкованій платі не залежно від того, де внесені зміни: у схемі або друкованій платі. Перенос змін схеми в друковану плату називається «прямій» коректуванням (Forward annotation), а перенос змін друкованої плати в схему називається «зворотною» коректуванням (Back annotation). Для цього рекомендується періодично виконувати наступні операції: , 

· після змін у друкованій платі по команді OrCAD Layout Auto>Back Annotate створюється файл зворотного коректування (*.swp); ці зміни вносяться в схему по команді OrCAD Capture Tools>Back Annotate; 
· після змін схеми складається файл її списку з'єднань (*.mnl) по команді Tools>Create Netlist, причому на закладці Layout команди потрібно відзначити опцію Run ECO для прямого коректування плати (нагадаємо, що перед створенням списку з'єднань потрібно скопіювати поточний файл конфігурації Layout.ini у каталог, у якому перебуває програма Capture.exe). 

При виконанні прямої й зворотного коректування варто мати на увазі наступне. При додаванні в OrCAD Capture нових компонентів у діалоговому вікні Update Part Reference варто вибирати опцію Incremental reference (але не Unconditional reference). Проведення нових електричних зв'язків іди видалення існуючих не передаються з OrCAD Layout в OrCAD Capture, тому всі подібні зміни виконуються в Capture і потім за допомогою механізму прямого коректування передаються в Layout. І навпроти, зміни позиційних позначень компонентів повинне бути виконане в Layout і потім за допомогою механізму зворотного коректування передані в Capture. 

 ЗАВДАННЯ

1. Створити список зв’язків та корпуси відповідних компонентів схеми за допомогою  OrCAD Capture разом з OrCAD Layout.
2. Зробити та захистити звіт з лабораторної роботи.

Лабораторна робота № 4.

Проектування друкованих плат 

Мета роботи: навчитись створювати друковану плату.

Теоретичні відомості.

Редактор топології друкованих плат OrCAD Layout 
Найбільш природний спосіб розробки друкованої плати (ДП) складається в створенні її схеми за допомогою одного із графічних редакторів, наприклад OrCAD Capture, і створення списку з'єднань схеми у форматі, прийнятному для OrCAD Layout.

Розробка нової ДП починається після завантаження OrCAD Layout (див. команди її початкового режиму в табл. 1) і виконання команди File>New. Спочатку запитується ім'я технологічного шаблона ПП (розширення імені файлу *.ТСН або *.TPL, мал. 1, а). Потім — ім'я файлу списку з'єднань *.MNL (мал. 1, б). На закінчення вказується ім'я файлу створюваної ДП *.МАХ (мал. 1, е). 

Таблиця 1. Команди OrCAD Layout Plus у початковому режимі 
	
	
	
	
	

	
	Команда 
	Призначення 
	

	
	Меню File (Файл) 
	

	
	New... 
	Створення проекту нової ДП із завантаженням файлів шаблона й списку з'єднань 
	

	
	Open... (Ctrl+O) 
	Відкриття існуючого проекту ДП 
	

	
	Import 
	Імпорт файлів ДП інших САПР: 
	

	
	
	MIN Interchange 
	Перетворення текстового файлу *.MIN у бінарний файл *.МАХ 
	

	
	
	MAX ASCII to MNL 
	Перетворення текстового файлу списку зв'язків *.ASC у бінарний файл *.MNL 
	

	
	
	РСВ II Netlist 
	Перетворення текстового файлу списку зв'язків *.NET системи P-CAD у бінарний файл *.MNL 
	

	
	
	Futurenet Netlist 
	Перетворення текстового файлу списку зв'язків формату програми Futurenet у бінарний файл *.MNL 
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Рис. 1. Завантаження списку з'єднань при створенні нової ДП.

Список помилок, що виникли при завантаженні списку з'єднань, виводиться в текстовий файл <ім'я_файлу_списку_з'єднань>.ЕRR (див. мал. 2). 
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Рис. 2. Звіт про результати завантаження списку з'єднань

У процесі завантаження списку з'єднань для кожного символу схеми в бібліотеках корпусів компонентів *.LLB (Footprint Libraries) відшукується відповідний корпус. 

Якщо в процесі завантаження списку з'єднань виявлений компонент, що не має посилань на його корпус, то виводиться діалогове вікно (мал. 3, а) для його визначення. Після натискання на панель Link existing footprint to component (Укажіть ім'я існуючого типового корпуса) відкривається діалогове вікно (мал. 3, б), у якому вибирається ім'я бібліотеки й потім ім'я корпуса, зображення якого проглядається в правій частині вікна. 

Технологічні шаблони (Technology templates, файли з розширенням імені *.ТСН або *.TPL) містять початкову інформацію про ДП: зазори й сітка трасування, дані про контактні площадки (КП) і перехідних отворах ( ПО) і т.п. Надалі всі ці установки можна змінити окремо або завантажити новий шаблон після створення ДП. У результаті завантаження технологічного шаблона в поточний проект вносяться наступні зміни: 

· завантажуються стратегії розміщення компонентів і трасування провідників, заміщаючи попередні дані; 

· установлюється нова структура шарів ДП; 

· змінюються розміри кроків всіх сіток: 

· змінюються параметри всіх стиків контактних площадок (СКП) виводів компонентів і ПО. 
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Рис. 3. Визначення корпуса компонента.

Після успішного завершення завантаження списку з'єднань на робочому екрані OrCAD Layout зображуються корпуси компонентів поточного проекту із вказівкою їхніх електричних з'єднань, як на прикладі показане на мал. 4. 
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Рис. 4. Результат завантаження списку з'єднань на друковану плату 

Розміщення компонентів виконується в OrCAD Layout вручну, по черзі вибираючи, переміщаючи, повертаючи й переміщаючи компоненти на поверхні зовнішнього шару ПП і переміщаючи пленарні компоненти на протилежну сторону. В автоматичному або інтерактивному режимах розміщення компонентів виконується по командах Auto>Place. 
Трасування провідників проводиться в ручному режимі за допомогою команд Tool>Track>Select Tool й Track Segment або в інтерактивному режимі за допомогою команд Auto>Autoroute (Autopath Route Mode, Shove Track Mode, Edit Segment Mode ). При інтерактивному трасуванні виконується поточний контроль дотримання припустимих зазорів, якщо включено режим Online DRC 
.Розміщення компонентів і трасування провідників в автоматичному режимі 
1. Автоматичне розміщення компонентів 

По команді Auto>Place>Board виконується автоматичне розміщення компонентів на всієї ДП. Авторозміщення виконується за кілька проходів (до 11) відповідно до правил, створюваним по команді Options>Placement Strategy, як показано на мал. 5. Редагування окремого параметра одного із проходів трасування або всіх його параметрів виробляється щиглик лівою кнопкою миші при розташуванні курсору в окремого осередку таблиці або на рядку з ім'ям проходу розміщення, як показано на мал. 6, а. 
Додатково по команді Options>Place Settings, як показано на мал. 6, б, задаються параметри стратегії авторозміщення компонентів, виконуваного по командах Auto>Place>Board й Auto>Place>Matrix Place. 
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Рис. 5. Таблиця стратегії проходів розміщення компонентів

2. Автоматичне трасування провідників 

Автотрасування провідників виконується потрійно. По-перше, OrCAD Layout містить у меню Auto групу відповідних команд, достатніх для розробки простих ДП [18]. По-друге, для розробки більше складних ДП призначена окрема програма SmartRoute, що використає алгоритми оптимізації нейронних мереж, аналогічна програмі Shape-Based Router пакета P-CAD 2000. По-третє, з метою розміщення компонентів і трасування провідників у ручному, інтерактивному або автоматичному режимі можна використати програму SPECCTRA , що не входить безпосередньо до складу системи OrCAD . Розглянемо коротко перші два способи. 
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Рис. 6. Редагування параметрів проходів авторазмещения

1 спосіб. Приватні параметри стратегії автотрассировки задаються в діалогових вікнах, показаних на мал. 7, які відкриваються по командах Options>Route Strategies програми OrCAD Layout. Глобальні параметри стратегії автотрассировки задаються в діалоговому вікні, показаному на мал. 8, що відкривається по команді Options>Route Settings.
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Рис. 7. Редагування параметрів стратегії трасування Manual Route (a), Route Layers (б), Route Sweep (в) і Route Passes (г)
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Рис. 8. Діалогове вікно Route Settings

2 спосіб. Програма SmartRoute викликається споконвічного меню програми OrCAD Layout або автономно, її основний екран показаний на мал. 9. 

Спочатку завантажується файл ДП *.МАХ і потім за допомогою команд меню Setup задаються параметри трасування в діалогових вікнах, показаних на мал. 11. У нижній частині вікна Parameters після натискання на панель Analyze Parameters указуються оцінки повноти трасування у відсотках й очікувані витрати часу (ці дані досить приблизні й для складних ДП не завжди відповідають фактичним результатам). При цьому треба враховувати, що з OrCAD Layout в SmartRoute передаються значення ширини трас всіх ланцюгів (Track Width) і припустимі зазори (Clearance). 

На закінчення по команді Options>Routing Passes (мал. 10) задається перелік проходів трасування (ROUTING PASSES) і проходів поліпшення технологічності плати (MANUFACTURING PASSES). Автотрассировка починається по командах меню Auto. Крім того, у програму SmartRoute включені команди трасування ланцюгів у ручному режимі Tools>Manual Route й Tools>Sketch a Track. Якщо SmartRoute завантажений з оболонки OrCAD Layout, то по закінченні трасування керування передається назад (однак файли ДП із однієї програми в іншу автоматично не передаються). 
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Рис. 9. Екран програми SmartRoute
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Рис. 10. Діалогове вікно команди Options>Routing Passes
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Рис. 11. Завдання параметрів трасування по командах Options>Net Properties (a) і Options>System Settings (б)
 ЗАВДАННЯ

1. Створити друковану плату.
2. Зробити та захистити звіт з лабораторної роботи.


